logo
ホーム •  フォーラム •  日本語wikiトップ •  アカウント情報 •  サイト内検索 •  新規登録
 ログイン
ユーザー名:

パスワード:


パスワード紛失

新規登録
 メインメニュー
 米国サイト
 オンライン状況
17 人のユーザが現在オンラインです。 (4 人のユーザが フォーラム を参照しています。)

登録ユーザ: 0
ゲスト: 17

もっと...

Re: 参加申し込み

このトピックの投稿一覧へ

通常 Re: 参加申し込み

msg# 1.1.1.1.1.1.1
depth:
6
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 .2 | 投稿日時 2008-2-2 3:25
sambar  長老 居住地: 岡山  投稿数: 484
引用:
以前別スレッドで話題になった fgcom ですが、Mac OS 上では無事構築できました。何度かテストをしてみましたが、今の所不具合も無く使えています。
当日迄にWindows 版が利用できるようであれば、こちらも使ってみたい気もしますね。
cygwin上では、libiaxclient.aとのリンク時に大量にundefined reference to 〜エラーがでました。

コンパイルは以下のオプションでやりました。
引用:
g++ -L/lib fgcom.o usage.o position.o ../iaxclient/lib/libiaxclient.a -lopenal -lplibul -lplibnet -lpthread -lm -o fgcom

エラーログの大半がlibiax2/src/iax.cのleft-hand operand of comma expression has no effect 警告とstatement with no effect 警告とリンク時のundefined reference to 〜エラーなので、ここでは重要そうな警告と、エラーの出ているファイル名を挙げる程度にしておきます。
#詳しいログを作業場に貼っても良いでしょうか?

コンパイル時に警告が出たファイル(「変数が未使用」等は省略)
引用:
portmixer/px_win_wmme/px_win_wmme.c
portaudio/src/hostapi/wmme/pa_win_wmme.c
libiax2/src/iax.c
libiax2/src/options.c(私が追加)

リンクエラー(一部)
引用:
Warning: resolving _sendto@24 by linking to _sendto
Warning: resolving _socket@12 by linking to _socket
Warning: resolving _bind@12 by linking to _bind
Warning: resolving _gethostbyname@4 by linking to _gethostbyname
Warning: resolving _inet_ntoa@4 by linking to _inet_ntoa
Warning: resolving _select@20 by linking to _select
/trunk/iaxclient/libiaxclient.a
/trunk/iaxclient/lib/iaxclient_lib.c
/trunk/iaxclient/lib/winfuncs.c
/trunk/iaxclient/lib/libiax2/src/iax.c
/trunk/iaxclient/lib/audio_openal.c
/trunk/iaxclient/lib/audio_portaudio.c
/trunk/iaxclient/lib/codec_speex.c.
/trunk/iaxclient/lib/codec_gsm.c
/trunk/iaxclient/lib/libiax2/src/iax2-parser.c
/trunk/iaxclient/lib/portaudio/src/common/pa_front.c
/trunk/iaxclient/lib/portmixer/px_win_wmme/px_win_wmme.c
/trunk/iaxclient/lib/libspeex/misc.c
/trunk/iaxclient/lib/portaudio/src/os/win/pa_win_util.c
/trunk/iaxclient/lib/portaudio/src/hostapi/wmme/pa_win_wmme.c
/trunk/iaxclient/lib/gsm/src/rpe.c
/lib/libplibul.a(ulClock.o): In function `_ZNK7ulClock10getRawTimeEv':
/usr/src/plib-1.8.4/src/util/ulClock.cxx:79: undefined reference to `_timeGetTime@0';


多分、libiaxclient.aのビルドが正常でないんじゃないかと思います・・・が、対処法が分りません。ご教授よろしくお願いします。

--
Powerd by Phenom X4_9350e, nVidia GeForce GTX550Ti,Linux(x86_64)
旧callsign=sambar
新callsign=JA26FB

投票数:14 平均点:4.29

投稿ツリー

  条件検索へ


 検索

高度な検索
 新しい登録ユーザ
korneliasl 2020-10-24
ezequs 2020-10-24
xepato 2020-10-24
ivykubidy 2020-10-24
axytyd 2020-10-24
byjewi 2020-10-23
jamswarner 2020-10-23
hadalabogo 2020-10-23
ewywuwifa 2020-10-23
wuqufyh 2020-10-23
 最近の画像(画像付)
あきづきに着艦訓練 (2020-5-24)
あきづきに着艦訓練
反映確認飛行 (2020-5-17)
反映確認飛行
AI艦船 護衛艦あき... (2020-5-16)
AI艦船 護衛艦あき...
コックピット内の謎... (2020-5-16)
コックピット内の謎...
FA-200に180ps仕様を... (2020-2-22)
FA-200に180ps仕様を...
Powered by XOOPS Cube 2.1© 2001-2006 XOOPS Cube Project
Theme designed by OCEAN-NET