logo
ホーム •  フォーラム •  日本語wikiトップ •  アカウント情報 •  サイト内検索 •  新規登録
 ログイン
ユーザー名:

パスワード:


パスワード紛失

新規登録
 メインメニュー
 米国サイト
 オンライン状況
19 人のユーザが現在オンラインです。 (8 人のユーザが フォーラム を参照しています。)

登録ユーザ: 0
ゲスト: 19

もっと...

FlightGear v1.9.0 リリース

  • このフォーラムに新しいトピックを立てることはできません
  • このフォーラムではゲスト投稿が禁止されています
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 .2 .3 .4 .5 .6 .7 .8 .9 .10 .11 .12 .13 | 投稿日時 2008-12-23 1:51 | 最終変更
toshi  長老   投稿数: 1529
開発者の皆さんのご尽力により、クリスマス前に FlightGear v1.9.0 がついにリリースされました。

現時点でダウンロード可能なコンパイル済みのファイルは、windows用インストーラ付きバイナリ(fgsetup-1.9.0.exe)と Slackware用バイナリです。
ダウンロード先、及び最新の情報については、
http://www.flightgear.org/Downloads/binary.shtml
をご覧ください。

windows用バイナリに関しては
ftp://ftp.ibiblio.org/pub/mirrors/flightgear/ftp/Win32/fgsetup-1.9.0.exe
からダウンロードするのがが比較的早そうな気がしますが、状況によって異なるかもしれません。

v1.9.0のリリースにあわせて、「FlightGear Aircraft Downloads」ページも更新されました。

シーナリーは、10/27付けで公開された「FlightGear World Scenery v1.0.1」を使うと良いでしょう。

FlightGear v1.9.0の変更点は
http://www.flightgear.org/version.html
に詳しく記載されていますが、私がwindows版を使ってみて気づいた点を以下に記します。

● うまく起動しない、あるいは起動後の画面に「黒い壁」が発生する(スクリーンショット)

--> windowsのデスクトップの「画面の色」を32ビットに設定することで解決しました(関連記事)。

● 起動や終了に異常に時間がかかる

--> FlightGearが使用するメモリ量が、v1.0.0では200MBだったのが、v1.9.0では500MB程度に増加しているようです。
不要なアプリケーションを終了するか、メモリの増設を検討しないといけないかもしれません(関連記事)。

● NumLockキーがオンの状態で、機体の操縦が出来ない
(追記: 「テンキーを使って」という言葉が抜けてました)
--> 今のところ原因と対処方法は不明です。

また、fsgikocatさんの投稿によりますと、黒い雨が発生することがあるようです(スクリーンショット)。
これについても、今のところ原因と対処方法は不明です(私の環境では問題が再現していません)。

以上です。
投票数:16 平均点:3.13
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 .2 | 投稿日時 2008-12-23 3:49
Tat  長老   投稿数: 375
Mac OS 版のリリースが完了しました。以下からダウンロード可能です。

http://macflightgear.sourceforge.net/

Mac 版特有の主な変更点は以下の通りです。
- インストーラの刷新 (より多くのデータがインストール/アップデート可能)
Nasal とか GUI Launcher のアップデートもやろうと思えばできます。
- Atlas のインテグレーション
- FGCom 設定の変更
- フランス語対応
- ログレベルの設定、閲覧
- データフォルダ参照可能

なお、私が知る限り Mac 版では、黒い雪や雨は降っていません。今の所黒壁も拝めてません。

それでは皆様よいクリスマスを!!
投票数:19 平均点:4.21
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-23 14:16
BBCTV  常連 居住地: 茨城県、日本国  投稿数: 96
1.9.0 for macダウンロードして使用してみましたが、相変わらずでした。

起動は正常ですが、「飛行開始」を押しても、フライト用のウィンドウが一瞬表示され、すぐに消えてしまいます。どの機種でも位置でも同じでした。

Read Meにあった、ターミナルに何か入力する、といった対処法をとってみましたが、かわりませんでした。

Mac 10.4.11
Intel Core Duo
投票数:23 平均点:3.91
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-23 14:35
Tat  長老   投稿数: 375
BBCTV さん

拡張機能から一般のタブを選び、「ログを閲覧」して見てください。
何か情報が得られるかもしれません。
投票数:17 平均点:4.12
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-23 19:30
BBCTV  常連 居住地: 茨城県、日本国  投稿数: 96
こんにひは。Tatさん。

ログには



Base package check failed ... Found version [none] at: /Applications/FlightGear\
Please upgrade to version: 1.9.0

とだけ出ていました。「飛行開始」押す前からです。
投票数:19 平均点:4.21
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-23 21:06 | 最終変更
zero1962  長老 居住地: 三重県  投稿数: 229
早速マルチアングル機能を確認してみたのですが、
結果は、以下のスクリーンショット
http://flightgear.jpn.org/modules/myalbum/photo.php?lid=104&cid=3

の通りでした。
解決策の画面のビット数を32に整合していることを確認しました。
なにか他の原因があるのではないでしょうか。(16ビットでも同じ)

スペックが重たすぎて現在使用マシンでは限界を感じてしまいます。
投票数:20 平均点:3.50
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-23 23:26 | 最終変更
toshi  長老   投稿数: 1529
zero1962さん、こんばんは。

v1.9.0、重たいですよねー。

軽く動かすための技は後でまた検討する事にして、v1.9.0の「黒い壁」問題についていくつか確認させてください。

1. マルチカメラ機能を使わないで起動したときに、windowsの色数を32ビットにしても「黒い壁」が発生するかどうか、教えてください。
問題の切り分けのために、ご自分で作成した設定ファイル等は用いない状態、つまり初期インストール状態での動作状況を知りたいです。
# 「黒い壁」に関するfsgikocat さんや私のレポートは、マルチカメラ用の設定ファイルを使わない状態での話をしています。

2. 利用環境(OS、ハードなど)を改めて教えてください。

3. 起動時オプションと、黒いコンソール画面に表示されているメッセージを教えてください。

4. zero1962さんのスクリーンショットをよーく見ると、fsgikocat さんや私が投稿したv1.9.0のスクリーンショットと異なる部分があるのですが、なぜそうなるのかお心当たりはありますか?
VistaとXPの違い、であれば良いのですが、実は古いFlightGearを起動してしまっている、なんてことはないでしょうか?
- メニューバーが「白地に灰字」(zero1962さん)、「灰地に白字」(fsgikocatさん、toshi)
- タイトルバー左の小さいアイコンが「OpenGL」(zero1962さん)、「ウィンドウスクリーン」(fsgikocatさん、toshi)

4.については、「黒い壁」問題とは関係ないかもしれませんが、基本的にはFlightGearのアップグレード時には、インストールをする「前に」古いFlightGearを削除する事をお勧めします(どこにも書いてありませんが)。
# そうしないと、スタートメニューに残ってしまったり、fgfs.exeが古い設定ファイルを参照してしまったり、といった不審な挙動をするケースがあるようです。

◎ FlightGearのアンインストール
● スタートメニューからFlightGearを辿って「Uninstall FlightGear」を使って、あるいはコントロールパネルからFlightGearを削除。
● Program Files/FlightGear フォルダを削除(またはリネーム)。
※デフォルト以外のディレクトリにインストールしていた場合は適宜読み替えてください。
● %appdata% フォルダにある flightgear.org フォルダを削除(またはリネーム)。
※「マイ コンピュータ」のアドレス欄に「%appdata%」と入れてください。
投票数:18 平均点:4.44
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-23 23:47
virtfly  常連   投稿数: 61
ようやくv1.9.0がダウンロードできたので、試してみました。

残念ながら私の場合も、黒壁が出現。色数を16ビットに落すと起動もできませんが、32ビットに戻しても黒壁を消失させることはできません。
黒壁は、色数とは別なところに原因があるような気がします。
なお、機体によっては(dhc2)黒壁の出現しないものもあります。

当方の環境は次の通り。
cpu:Core2DuoT7300 2.0GHz memory:2GB VIDEO:インテルグラフィック・メディア・アクセラレータX3100 os:WindowsVista Ultimate
投票数:17 平均点:3.53
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-24 1:02 | 最終変更
toshi  長老   投稿数: 1529
vitrflyさん、こんばんは。

レポートありがとうございました。

デスクトップの色数を32bitにしても「黒い壁」が発生するとのこと、了解です。
また、dhc2では「黒い壁」が発生しないというのは新たな発見ですね。
ためしに私も16bitの状態でdhc2で起動してみたところ、「黒い壁」は発生しませんでした。

貴重なレポートだと思いますので、英語フォーラムに記事を投稿しました。
あちらでは、"Big Black Box"問題と呼ばれています。
http://www.flightgear.org/forums/viewtopic.php?f=2&t=2585

誠に勝手ながら、記事中にfsgikocatさんとvirtflyの動作環境を記載させていただきましたので、どうかご了承ください。

ユーザレベルで対処できる解決法が見つかるか、あるいは修正済みのバイナリが再配布されることを願っています。
投票数:18 平均点:3.89
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-24 20:42
sambar  長老 居住地: 岡山  投稿数: 484
私も試してみましたのですが、以下の条件では黒壁は出ていませんでした。

CPU:Phenom X4 9350e
メモリ:DDR2 6GB
OS:WindowsVista(x64) Ultimate
VIDEO:Ati RadeonX1950(ASUS EAX1950Pro)×2 (Crossfireオン)
Windowsの画面設定:1680x1050 , 32ビット
fgfs.exeの起動オプション
--fg-root=D:/Program Files (x86)/FlightGear/data
--fg-scenery=D:/Program Files (x86)/FlightGear/data/Scenery
--aircraft=c172p
--disable-random-objects
--disabe-ai-models
--geometry=800x600
--timeofday=noon

まだ、この条件以外、特に雨や霧の時にどうなるかは試していませんし、dhc2でもまだ試していませんが、何かの参考になればと思います。
投票数:19 平均点:4.21
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 .2 .3 | 投稿日時 2008-12-24 21:28
zero1962  長老 居住地: 三重県  投稿数: 229
私は2台のPCで実験しております。
メインPC
FUJITSU FMV-DESKPOWER CE70E7
CPU      :Intel(R)Pentium(R)4 CPU 2.60GHz
RAM      :0.99GB
Windows XP Home Edition Version 2002 Sevice Pack2
新しいバージョンv1.9.0のfgfs.exeを起動していることに間違いないのですが、メニューバーの文字が白くなく黒であるのは正しくないのでしょうか?また、マルチカメラアングル無しの状態でも、左上1/4画面ほど黒い壁が発生します。

起動時のオプションは次のとおり。
C:/relax/FlightGear(1.9.0)/bin/Win32/fgfs.exe
--fg-root=C:/relax/FlightGear(1.9.0)/data
--fg-scenery=C:/relax/FlightGear(1.0.0)-org/scenery/;C:/relax/FlightGear(1.9.0)/data/Scenery/;C:/relax/FlightGear(1.9.0)/scenery/;C:/relax/FlightGear(1.9.0)/terrasync/
--airport=RJTT
--runway=34R
--aircraft=j3cub
--control=joystick
--disable-intro-music
--disable-random-objects
--prop:/sim/rendering/random-vegetation=false
--disable-panel
--disable-hud-3d
--disable-specular-highlight
--disable-ai-models
--disable-clouds
--shading-flat
--fog-disable
--geometry=1280x512
--visibility=10000
--bpp=32
--timeofday=noon
--callsign=zero62b
--multiplay=out,10,mpserver02.flightgear.org,5000
--multiplay=in,10,FMV,5000
--ai-scenario=AI_demo
--generic=file,out,10,fltrec.csv,playbackEx


サブPC
SONY VAIO VGN-G1
CPU      :Genuine Intel(R)CPU U1400@1.20GHz
RAM      :1GB
Windows Vista Business Sevise Pack 1
でございます。
こちらは、Fgrun.exeの段階で選択機体がちらちらとチラついて安定しません。また、runで起動するとタイトル画像が残ったまま、HUDが表示され、コクピットは見えません。Vキーで視点を変えても変化なしです。
ほとんど使えない状態です。
(ちなみにV1.0.0は、FMVより調子がいい)
投票数:19 平均点:4.74
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-24 21:29 | 最終変更
fsgikocat    投稿数: 6
みなさん今晩は。
当方の環境のみ、しかも v1.9.0 になってから発生していた黒い雨、雪ほかの
件についての続報です。

当方の以前の環境では v1.99.5-rc2 の時点から3D雲の表示がおかしく、
ビルボード(立て板)状の表示になってしまう現象が出ていましたが、それに
ついての情報をUSA本家のフォーラムで探していたところ
「OpenGLのドライバが古い場合にそのような現象が発生する」
との投稿を発見しました。そこでグラフィックボードのドライバを最新に更新して
みたところ、3D雲が正しく表示されるようになりました。
さらに、1.9.0 の時点で黒くなってしまった雲や雪が元通り正しく表示される
ようになりました。

なお、ドライバ更新してもWindowsデスクトップスクリーンを16ビットカラーに
設定した場合は fgfs のカラー設定が32でも16でも、やはり黒い壁が発生します。
また、ためしにここで dhc2 を起動してみますと、他の方と同様 dhc2 では
黒い壁が発生しませんでした。

ついでですが、1.9.0 の雲などの表示設定で気がついたことを。
fgfs のメニューバーの Environmente からプルダウンメニューで各種設定が
できますが(雪や雨もここで簡単に設定できます)、このとき Weather Senario を
NONE 以外にしますと Clouds の設定が無視されます。
フレームレート改善のために雲量の調整を色々ためしてみる場合には、これを
NONE に設定するほうがよいと思われます。
※しかしながらせっかく苦労して調整しても一度 fgfs.exe を再起動すると
  設定が戻ってしまう・・現在の設定を名前をつけて Weather Senario に
  保存できるようになると便利かな?と思いました。

以上 1.9.0 についての報告でした。
投票数:20 平均点:3.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-24 22:06 | 最終変更
zero1962  長老 居住地: 三重県  投稿数: 229
続報:FMVでは、
dhc2では、黒ベタは、発生しませんでした。また、マルチカメラアングルも正常に表示できました。

http://flightgear.jpn.org/modules/myalbum/photo.php?lid=107&cid=2

ちなみにdhc2のエンジン起動方法がわかりません。
投票数:15 平均点:2.67
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-25 0:28 | 最終変更
virtfly  常連   投稿数: 61
dhc2の発進手順です。

1)magnetoスイッチ(パネルに2つあるうちの右側の赤いレバーのスイッチ)をboth位置に。
2)燃料タンクスイッチ(左側の赤いレバーのスイッチ)を入れる。helpではrear tank位置にと書かれている。
3)操縦桿に一部隠れている横一列に並ぶトグルスイッチの一番左にあるBATTと表記のあるスイッチを入れる。
4)FUEL PUMPと表記のあるスイッチを入れる。
5)sキーを押すかstarterと表記のあるスイッチをクリック。
6)エンジンがかかったらalternatorスイッチを入れる。

どこかでスロットルレバーを上げておかねばなりませんが、5)まででエンジンがかかり滑走しだし、離陸します。なのでhelpに記されている6)の手順が必要なのかよくわかりません。

なお、3)以降のスイッチ操作の際に邪魔になる操縦桿は、メニューバーの[Beaver]をクリックして[Show/Hide Yokes]を実行させれば、操縦桿が消えて操作しやすくなります。
投票数:18 平均点:4.44
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-25 5:06
takehiro  長老 居住地: Kawasaki  投稿数: 101
主旨から外れたレスですみません。
Alternatorというのは日本語で言うと整流型交流発電機というものです。
どこまで模擬されているのかはわかりませんが、Alternator(や、Generator といった Engine Driven な発電機)を用いない場合、機上装備品への電力は Battery から供給されることになります。
通常 Battery から供給される電力は必要最低限な装備品にのみ供給されるよう Bus がわかれています。

ちなみに Engine の Spark Plugs には Magneto という磁石発電機がエネルギーを供給しています(小型機)。
投票数:16 平均点:1.88
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-25 16:35
Tat  長老   投稿数: 375
BBCTVさん
インストール先のフォルダにスペースが入っています。
これを取り除けば問題なく動作するはずです。
ちなみにこれは ReadMe にも記述されています。
投票数:15 平均点:3.33
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-27 14:44
TOMOYA  常連 居住地: 幻想郷と夕暮れの里の間の里  投稿数: 31
お久しぶりです★
インストール&起動してみたんですが、
どの機体、オブジェクト共に影が全く表示されません!

XP SP3(32bitPC)
CORE2DUO E8500 3.16MHz
nVidia GeForce 9600GT 1GB GDDR3
3.25GBメモリ

なんだか、寂しくて・・・
解決法ご存知の方はご教示頂けますようお願い致します。
投票数:17 平均点:4.12
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-27 17:29 | 最終変更
toshi  長老   投稿数: 1529
TOMOYAさん、ご無沙汰しております。

v1.9.0には影がまだ実装されていないので、影を表示させる事は残念ながら出来ません。
http://flightgear.jpn.org/modules/d3forum/index.php?post_id=1886

そのほかに、私の環境では以下の現象が生じています。

NumLock Onのとき、数字のテンキー(0〜9)が動作しない
- スロットルなどの操縦が出来ない
-- ただし、Shiftキーを押しながら0〜9キーを押すと操縦できる
-- あるいは、NumLock Offにすれば操縦できる
- プロパティツリーのdevices/status/keyboard/event が変化しない。
- Nasal Consoleにも書き込めない

マウスを右クリックして操縦モードや視点操作モードにしても、マウスカーソルの形状が通常のポインタ形状のまま
- 実際にはモードが切り替わっている
- マウスを動かすと、瞬間的に十字マークや⇔マークがちらちらと見える
投票数:18 平均点:4.44
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-27 18:15 | 最終変更
toshi  長老   投稿数: 1529
zero1962さん

toshiです。

各マシンにおいて、コンソール画面に表示されている(はずの)エラーメッセージを教えていただけませんでしょうか?

以下、これまでに皆さんから頂いたレポートに私の検証を追加して、【黒い壁】問題をまとめておきます。

◎FlightGear v1.9.0 【黒い壁】問題 (2008.12.27現在)

● プラットフォーム
Windows: 多くの環境で発生 (発生しない場合もある)
Mac: 今のところ発生報告無し

● 機体
v1.9.0 ベースパッケージで私が検証した限りでは、
- 黒い壁が生じる: 777-200, A6M2, c172p, CitationX, Dragonfly, f-14b, j3cub, sopwithCamel, ufo
- 黒い壁が生じない: b1900d, bo105, dhc2, senecaII, ZLT-NT

● 原因
はっきりした原因は不明。
ただし、何らかの理由により、使用しているビデオカードがサポートしていない描画機能を、FlightGear(あるいはSimGear、OpenSceneGraph)が使おうとしてしまうことに起因しているように思います。


● 全ての環境に有効な解決策
今のところ、不明。
ユーザレベルでは対処できない可能性も。

● 環境によってはうまくいく対処方法

1. ビデオカードのドライバを最新にする

- デスクトップPC向け
-- Nvidia: http://www.nvidia.co.jp/Download/index.aspx?lang=jp
-- AMD (旧ATI製品): http://ati.amd.com/support/driver.html
-- Intel: http://support.intel.co.jp/jp/support/graphics/

- ノートPC向け
-- 各PCメーカ(東芝, ソニー, パナソニック etc.)のページからさがしてください。
-- あるいは、自己責任になりますが、チップセットメーカ(Intel)が提供している最新のドライバをお試しください。

多くの場合、ドライバを最新にすることによりOpenGL関連の拡張機能が向上します。
これにより、うまくいくようになることがあります。

2. Windowsのデスクトップの色数を32bitにする

上記の対処を行っても【黒い壁】が消えない方は、ご使用の環境(特にグラフィックス)と共に、コンソール画面に表示されているエラーメッセージを教えてください。
有効な解決策をご提示できる保証はありませんが、何か分かるかもしれません。


----
余談ですが、自分のビデオカードがOpenGLの拡張機能にどの程度対応しているかを調べるには、Windows環境では以下のソフトが便利です。
但し、FlightGearがどのOpenGL拡張機能を必須要件としているのかは、私には分かりません。

窓の杜 - OpenGL Extensions Viewer
http://www.forest.impress.co.jp/lib/sys/hardcust/vdodsply/openglexview.html

ちなみに、私の NVIDIA GeForce 6150 LE では、最新の178.24ドライバを用いた場合、OpenGL 2.1 と表示されます。
投票数:24 平均点:5.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-27 23:54
sambar  長老 居住地: 岡山  投稿数: 484
少々横道にそれますが、タイトルバーの色はShift+F10で、茶色地に白(デフォルト)→白地に黒(0.9.10以前のスタイル)→茶色地に白、に変更できますよ。
ちなみに、F10でタイトルバーの表示、非表示の切り替えが出来ます。

#おそらく、古いfg_rootを参照しているのでは無いかと思います。

--
Powerd by Phenom X4_9350e, nVidia GeForce GTX550Ti,Linux(x86_64)
旧callsign=sambar
新callsign=JA26FB

投票数:21 平均点:2.86
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-28 0:47 | 最終変更
toshi  長老   投稿数: 1529
引用:

少々横道にそれますが、タイトルバーの色はShift+F10で、茶色地に白(デフォルト)→白地に黒(0.9.10以前のスタイル)→茶色地に白、に変更できますよ。
ちなみに、F10でタイトルバーの表示、非表示の切り替えが出来ます。

なるほど、そうだったのですか、知りませんでした。
情報ありがとうございます。

引用:
#おそらく、古いfg_rootを参照しているのでは無いかと思います。

いえ、そうではないと思います。

zero1962さんの起動時オプションは
--fg-root=C:/relax/FlightGear(1.9.0)/data
ですので、正しくv1.9.0のデータを読んでいると思います。

恐らく、FlightGear実行時に自動保存される設定ファイル %appdata%\flightgear.org\autosave.xml が過去に使っていたFlightGearから引き継がれてしまっているか、単にShift-F10を押したことがあり、その設定が保存されているのではないかと思います。

ということで、zero1962さんのお書きになった
引用:
新しいバージョンv1.9.0のfgfs.exeを起動していることに間違いないのですが、メニューバーの文字が白くなく黒であるのは正しくないのでしょうか?
とのご質問に対する回答は、「特に問題ないです」ということになります。

その他の問題点に対する回答は、「2008-12-27 18:15付けの記事」の中の私の質問に対するお答えを聞いてからにします。

ただ、シーナリーについては
--fg-scenery=C:/relax/FlightGear(1.0.0)-org/scenery
/;C:/relax/FlightGear(1.9.0)/data/Scenery/;C:/relax
/FlightGear(1.9.0)/scenery/;C:/relax/FlightGear(1.9.0)
/terrasync/
ですので、FlightGear(1.0.0)-org/scenery フォルダ内のシーナリーを読み込んでしまう可能性はあります。
これは、%appdata%\flightgear.org に古いFlightGearの設定ファイルが残った状態で 別のFlightGear をインストールした場合に見られる現象です。

FlightGearは、--fg-sceneryのリストに書かれた順にシーナリーを探しに行きます。
例えば、FlightGear(1.0.0)-org/scenery フォルダに以前の国内のシーナリーがインストールされたままになっている場合、FlightGear(1.9.0)/scenery に最新の国内のシーナリー(v1.0.1)をインストールしても、RJTT(羽田空港)のターミナルが表示されないといった現象が発生することが予想されます。

私がお勧めするFlightGearのアンインストール方法は、「2008-12-23の記事」で解説してあります。
投票数:19 平均点:3.68
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-28 2:29 | 最終変更
virtfly  常連   投稿数: 61
 黒壁問題がまだ話題になっているようですので、この問題を含めてv.1.9.0に関するおかしな現象を報告しておきます。

【黒壁問題】
○ドライバの更新で解消
 ドライバの更新くらいで解消するとは思わなかったのですが、ビデオカードがオンボードのチップセットのドライバを更新したところ、黒壁は当方の環境でも解消することができました。ドライバの更新は最後の選択肢として、とりあえずは更新せずにいろいろと試していましたので、以下に更新前の状況を記しておきます。
○c172pでも黒壁が発生しないものもある
 デフォルトで用意されている機体に関しては、発生の有無についてToshi様が確認の労をおとり下さっていますが、今一点興味ある事例を報告します。
 c172pでも、黒壁が生じない機体があります。c172p-panel-onlyなら黒壁は現れません。
○黒壁にレーダーの一部のようなキャラクターが表示される
 v.1.0.0版のme262におなじくOV10のレーダーを移植したケースでの話しですが、(レーダーのことはわからないので変な表現の仕方をしますが)しばしばレーダーに現れた±あるいは士の字に似たキャラクターと同じものが黒壁上に出現します。もともと移植はみようみまねでおこない、不完全なものである可能性は高く、v.1.0.0版のパッケージのマイナーバージョンアップ時すでにレーダー画面が向きの変化により白っぽくなるという現象があり、今回のv.1.9.0ではドライバ更新後もコクピット内のレーダー横にミニ白壁問題というほどではないですが灰色の四角が出現しています。なお、オリジナルのme262でも黒壁は発生します。

――ドライバの更新で黒壁が解消するということは、明らかにビデオカードの能力に関する問題であることははっきりとしており、やhり非力なマシンではあきらめざるをえないということでしょう。しかし、機体によってあるいは同じ機体でもバリエーションによって、黒壁が発生したりしなかったりというのも変な話です。黒壁の発生しない機体にはOSGとわざわざ記したものがあります。OSGでないと動きませんよということであればそれまで、うがった見方をしてOSGに対応を謳ったものならば、適したつくり方というものがあることになります。そうであれば非力なマシンにとって光明となるのですが。上述の例からは、パネル周りが臭い気もします、――

【雪が再現できる場合とできない場合がある】
 当方の環境では、ドライバの更新前ですと、唯一Cessna Citation-Xのみ、雪が再現されました。ただし後景のみ、前景はは降らないというあやしい降り方ですが。更新後は雪が再現(もちろん正常な降り方で)される機体は増えましたが、それでもまだ雪を降らそうとすると「fgfs.exeは動作を停止しました」が表示されウインドウが閉じてしまうものがあります。

【航跡がいつまでも消えない】
 mc72を海上に浮かべたところ、まず生じた波紋が黒い(一部白いところもあるが)というのもおかしいが、足跡のようにいつまでも消えません。ドライバの更新で解消。ただし水煙はv.1.0.0の方が個人的には好みです。

【コクピットが消えてしまう】
 c172pでは、デフォルトのコクピット画面で、ビューモードにして少しカーソルを動かすと、何故かコクピット(というか機体)が消えてしまいます。

【右方向へのラダーが効かない】
 どの機体の場合でも、右方向へ進もうとエンターキーを押しても垂直尾翼は微動だにしません。これは痛い。

【その他】
○3D雲
 挙動がおかしいというものではありませんが、3Dの雲はリアリティにかけます。チカチカするのもどうかと。
○コクピット後方を振り返れない
 仕様なのでしょうが、ビューモードでコクピット後方を振り返れなくなっています。
○v.1.0.0で動いたものが動かない
 v.1.9.0に問題があるのではなく、自分でいい加減なプログラムを作成したもの(本来の方法をとらなかったライトなど)がもっぱらなのですが、v.1.9.0では動かないものが、多々あり、冷や汗もの。オリジナルでLightningのエクゾーストが大気の揺らぎを再現していたのが、ダメになっているのは残念です。

 v.1.9.0の良いところも触れるべきでしょうが、長くなりましたのでこれで筆をおきます
投票数:16 平均点:5.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-28 16:57
Tat  長老   投稿数: 375
nVidia チップを使用している Mac 上でFlightGear 1.9.0 のスプラッシュスクリーン表示中にクラッシュが発生するという報告を幾つか受けました。

これは以前からある問題でして、ある程度の対策はしていたのですが、予想よりも多くの nVidia カードで問題が発生しているようです。問題は NVIDIA のドライバにあるようで、マルチスレッド環境で ハードウェアミップマッピング時にクラッシュします。

これに伴い ドライババグを回避する為の対症療法を施した osg フレームワークを配布しています。以下のリンクにある osg.framework をクリックして osg.framework.tar.gz をダウンロードして、GUI ランチャの
拡張機能 >> その他 >> データをインストール
からインストールしてください。

http://macflightgear.sourceforge.net/workaround-patch-for-nvidia-drivers

その後 GUI ランチャを再起動すれば問題は回避されます。
なお、このパッチが必要なのは NVIDIA ドライバを利用している Mac で、かつ
毎回スプラッシュスクリーンでクラッシュする場合のみです。
投票数:18 平均点:3.89
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-29 0:37 | 最終変更
Tat  長老   投稿数: 375
Windows 上で 黒い壁が発生するという問題についてですが、NVIDIA の過カードをお使いの場合、OSG_MULTIMONITOR_MULTITHREAD_WIN32_NVIDIA_WORKAROUNDという環境変数を ON にしてみてはいかがでしょうか?
# Windows 版 FG をお使いの方、Windows 環境下で FG 起動前にこの環境変数を設定する方法の詳しい説明をお願いします。

というのも、OSG のソースを眺めていたら GraphicsWindowWin32.cpp という Windows 固有のソースに以下の様な記述がありました。
引用:
// 2008/05/12
// Workaround for Bugs in NVidia drivers for windows XP / multithreaded / dualview / multicore CPU
// affects GeForce 6x00, 7x00, 8x00 boards (others were not tested) driver versions 174.xx - 175.xx
// pre 174.xx had other issues so reverting is not an option (statitistics, fbo)
// drivers release 175.16 is the latest currently available
//
// When using OpenGL in threaded app ( main thread sets up context / renderer thread draws using it )
// first wglMakeCurrent seems to not work right and screw OpenGL context driver data:
// 1: succesive drawing shows a number of artifacts in TriangleStrips and TriangleFans
// 2: weird behaviour of FramBufferObjects (glGenFramebuffer generates already generated ids ...)
// Looks like repeating wglMakeCurrent call fixes all these issues
// wglMakeCurrent call can impact performance so I try to minimize number of
// wglMakeCurrent calls by checking current HDC and GL context
// and repeat wglMakeCurrent only when they change for current thread

これの 2 において、GeForce のドライババージョン 174.xx - 175.xxにおいて、マルチスレッド/デュアルビュー/マルチコアな Windows Xp で FramebufferObjects でおかしな挙動をすることが説明されています (FlightGear はマルチスレッド/デュアルビュー(カメラ)です)。この現象が発生する場合には環境変数の設定で
OSG_MULTIMONITOR_MULTITHREAD_WIN32_NVIDIA_WORKAROUND=ON
とするようにと書かれています。174以前のドライバはその他の問題もあるそうですので、ドライバを最新版にする事が前提だそうです。

ちなみに、OSG の MLを 少し検索してみると この投稿 には toshi さんの報告にあったエラーと同じ内容が記述されています。その時の解決法として紹介されていたのがこの方法です。

ATI や Intel GMA 系チップの問題はこれでは解決できませんが、ご参考迄。
投票数:16 平均点:6.25
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 .2 | 投稿日時 2008-12-29 1:56 | 最終変更
toshi  長老   投稿数: 1529
tatさん

toshiです。

情報ありがとうございます。

まず、JPフォーラムの報告を整理しますと以下のようになり、NVIDIA系はとりあえず【ドライバを最新版に】して、かつデスクトップの色数を32ビットにすれば黒い壁は現れていないようです。
つまり、nvidia系で困っているユーザは、今のところいません。

なお、英語フォーラムのユーザの情報は、最新のドライバを使っているかどうか把握できていないので、ちゃんと整理していません...

toshi: NVIDIA GeForce 6150 LE (最新ドライバ178.24)
- デスクトップの色数が16ビットだと黒い壁が発生
- デスクトップの色数を32ビットにすれば解決

fsgikocatさん:、NVIDIA GeForce 6200
- デスクトップの色数が16ビットだと黒い壁が発生
- デスクトップの色数を32ビットにすれば解決

virtflyさん: Intel GMA X3100
- ドライバの更新前は黒い壁が発生
- ドライバの更新によって解決

sambarさん: Ati RadeonX1950(ASUS EAX1950Pro)×2 (Crossfireオン)
- 色々やってみても、黒い壁は発生しない

一方、zero1962さんのFMVについては、黒い壁の問題が発生していると思われますが、どのようなエラーメッセージなのか、あるいはドライバが最新かどうかは分かりません(質問しているつもりなのですが、返答はまだ頂いていません)。

zero1962さん: (多分)Intel 865GV
- 黒い壁が発生
- ドライバが最新かどうかは不明
- Intelのサポートが終了しており、最新のドライバでも2005/09/28付けのため、どうなるかちょっと心配

それから、Tatさんの情報を元にして、NVIDIAでデスクトップ色16ビットでも黒い壁が発生しなくなるかどうか試してみましたが、残念ながら効果はなく、相変わらず"FBO setup failed"になって黒い壁が発生してしまいました。
C:\>set OSG_MULTIMONITOR_MULTITHREAD_WIN32_NVIDIA_W
ORKAROUND=ON

C:\>cd "c:\Program Files\FlightGear1.9.0\bin\Win32"


C:\Program Files\FlightGear1.9.0\bin\Win32>fgfs --fg-root="c:\Program Files\Flig
htGear1.9.0\data" --fg-scenery="c:\Program Files\FlightGear1.9.0\scenery;c:\Prog
ram Files\FlightGear1.9.0\data\Scenery"
  Model Author:  Unknown
  Creation Date: 2002-01-01
  Version:       $Id: c172p.xml,v 1.20 2008/09/01 15:14:33 torsten Exp $
  Description:   Cessna C-172
FGMultiplayMgr - No receiver port, Multiplayermode disabled
KI266 dme indicator #0 initialized
RenderStage::runCameraSetUp(), FBO setup failed, FBO status= 0x8cdd
RenderStage::runCameraSetUp(), FBO setup failed, FBO status= 0x8cdd
Initializing Nasal Electrical System
power up

C:\Program Files\FlightGear1.9.0\bin\Win32>

また、実は私も同じOSG MLの投稿を数日前に読み、うまく動作するという175.19 ドライバにダウングレードしてみたのですが、特に効果はありませんでした。

今後についてですが、英語フォーラムにも書いたのですが、Tim Mooreがさっそくコードの修正を始めているようです。
http://mapserver.flightgear.org/git/gitweb.pl?p=flightgear;a=commit;h=9100a0c3b84360cd667841fdab6eacd398024ed8

near-fieldを0とすれば、far cameraを使わずに1つのカメラで描画するとのことですので、これで解決出来るのではないかと期待しています。

今後、windows用cvsスナップショットバイナリが公開されたら試してみようと思います。
投票数:16 平均点:3.75
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-29 2:46
Tat  長老   投稿数: 375
toshi さん

そういえば彼が何か対策するとか言ってた気がしますが、これだったんですね。
--prop:/sim/rendering/camera-group/near-field=0 を指定して起動すると
Near カメラのみで描画するので、マルチビューで発生するドライバのバグは回避できることになりますね。Windows 版はかなりこの現象が問題になっているので、解決できればいいですね。
投票数:18 平均点:3.89

なし zero1962の現象

msg# 1.8.1.1.2
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-29 9:30
zero1962  長老 居住地: 三重県  投稿数: 229
すみません、エラー情報報告がおくれまして。実は、実家に帰省していたので手元にメインPCのFMVがありません。もうしわけありません。
また、サブPCのVaio では、コンソール画面になにもエラー表示はでないのでなにも申し上げられないのですが、グラフィック・アクセラレータがうまくOpenGLに対応していない気がします。デバイスドライバの更新を試みましたが、すでに最新のものが入っているようです。
投票数:12 平均点:2.50

なし Re: zero1962の現象

msg# 1.8.1.1.2.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-29 10:57 | 最終変更
toshi  長老   投稿数: 1529
zero1962さん

FMVが手元に無い件、了解です。

すみません、お返事をせかせたつもりではなかったのですが、投稿が増えたので紛れてしまったかもしれないと思って、質問に対するご回答待ちであることを書かせていただきました。

それから、VAIOの方はサブPCとのことで、うまく動かなくてもお困りになることはないかと思ったので特に返事をしませんでしたが、こちらでもFlightGearを動かすつもりはありますか?

ちなみに、こちらは「黒い壁」とは別の、以下のスクリーンショットにあるような起動時の不具合かなと思います。
http://www.flightgear.org/forums/viewtopic.php?f=2&t=2705

このスクリーンショットを投稿した人はATIを使っていて、ドライバのアップグレードにより、次の段階の「黒い壁」問題にたどり着いたようです。

ノートPCの場合、PC製造メーカのドライバを使う事が推奨されていますので、Intelなどのチップセットメーカよりもドライバの更新が遅れてしまう、ということはあるかもしれません。

私は手元のノートPCに、Intel の Mobile Intel 965 Express ドライバを「えいや」と入れてみて、デスクトップの色数が32ビットなら起動する事を確認しましたが、あくまで自己責任ということでお願いします。

# 16ビット色時に発生するエラーは「2008-12-21 23:57の記事」をご参照ください。
投票数:18 平均点:5.56
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-29 18:20
tiger  常連   投稿数: 51
みなさん、今晩は。Tigerです。
多くの情報ありがとうがざいます。まだ使い始めですが現在のところ不具合が2点あります。

1.OSG版の特徴であるRandom treeが全く表示されません。(Wizardのチェックボックスは入力確認済みです)
2.マウスポインターが不安定です。
画面の色数は16ビットで黒壁発生、32ビットで問題ありません。

v1.9.0の印象ですが3D雲が美しく機体の質感も向上して全般的には前バージョンよりグレードアップしたと思います。なによりPNGファイルをRGBに変換しないですむのが助かります。

CPU:pentium 4
OS:Windows XP HE,sp2
VIDEO:Geforce6800(ドライバ178.24)
Windowsの画面設定:800x600 , 32ビット
投票数:17 平均点:2.94

なし Re: zero1962の現象

msg# 1.8.1.1.2.1.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-30 12:09
zero1962  長老 居住地: 三重県  投稿数: 229
toshiさん、こんにちは、年末お忙しいなか、ご返事いただきありがとうございます。
私のサブPCのVAIO VGN-G1は、V1.0.0は結構、良好に動作し、ボランティアの現場でも活躍しています。

V.1.9.0で困っている現象は、ご指摘のように、RUNで起動開始してもHUDが表示されているのにコクピット画面に切り替わらない現象で、同じ不適合と考えられます。

VGN-G1のディスプレィアダプタのデバイスドライバの更新を試みましたが、最新のドライバであるということで更新はされませんでした。

また、チップメーカのから適合するドライバをインストールする勇気がいまひとつ出ません(臆病者です…)

しばらくは、V1.0.0で満足していようと思います。
投票数:19 平均点:4.74

なし Re: zero1962の現象

msg# 1.8.1.1.2.1.1.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-30 15:14
Tat  長老   投稿数: 375
この現象はMac でもたまに発生します。
幸いなことに一度終了して起動し直すと問題なく動作します。

スプラッシュスクリーン時に終了するとクラッシュしますが、無視して問題在りません。

この現象は現在調査中ですので、そのうち修正されるでしょう。
次の正式リリースがいつになるかはまだ討議中ですが、比較的早くリリースされることが予測されます。
投票数:13 平均点:3.08

なし Re: zero1962の現象

msg# 1.8.1.1.2.1.1.1.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-31 0:55 | 最終変更
BBCTV  常連 居住地: 茨城県、日本国  投稿数: 96
遅くなりましたが、
Tatさん:
Macでの起動について、回答ありがとうございます。新スレ癖については、申し訳ありません。今後気をつけたいと思います。

あと....スペースって何ですか?これはすごく幼稚な質問かもしれませんが、よく理解できません。他のトラブルに関する事で話し合っている最中申し訳ないのですが、できれば教えてください。
投票数:18 平均点:5.00

なし Re: zero1962の現象

msg# 1.8.1.1.2.1.1.1.1.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2008-12-31 2:05 | 最終変更
toshi  長老   投稿数: 1529
BBCTVさん

「スペース」とは、キーボードのスペースキーを押すと入力される「空白文字」のことです。

現在の Mac OS X 版は、インストール先フォルダの名前に空白文字が含まれているとうまく起動できないので、空白文字を含まないフォルダにインストールしてください、という意味です。
投票数:17 平均点:3.53

なし Re: zero1962の現象

msg# 1.8.1.1.2.1.1.1.1.1.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2008-12-31 14:49 | 最終変更
BBCTV  常連 居住地: 茨城県、日本国  投稿数: 96
Tatさん, toshiさん:
Macで飛行出来るようになりました。

フォルダ名のスペースのことだったのですね。"FlightGear 1.9.0"ではなく、"FlightGear1.9.0"にすると。もっと複雑なことなのかと勘違いしていました。ありがとうございました。これでやっと、このスレッドの大抵の話題にはついていけるようになりました。

まだMacではよく試していないので、何かあったら後で連絡します。

Tatさん、toshiさん、ありがとうございました。

PS: wikiのMac向けインストール解説ページ、かなり簡単に1.9.0のことも書いておきました。0.9.10と1.0.0と混じって、少し分かりにくいのですが...
投票数:14 平均点:2.86
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 .2 | 投稿日時 2009-1-1 14:12 | 最終変更
toshi  長老   投稿数: 1529
来週になるとまたほとんど時間が取れなくなるので、ひとまず 【windows 用】 FlightGear 1.9.0 の現状についてまとめておきます。

◎重大な不具合は2点
o 「黒い壁」
- 解決に向けてコードの修正が進行中です。
- 近いうちにアップデート用バイナリが配布されるのではないかと思います。
- 参考
-- 本家フォーラム: http://www.flightgear.org/forums/viewtopic.php?f=2&t=2585
-- 開発メーリングリスト: http://www.mail-archive.com/flightgear-devel@lists.sourceforge.net/msg20101.html

o 起動時に「loading scenery objects」画面で非常に時間がかかる
- 私の知る限りですが、解決策は不明です。
-- メニューバーで何度か File > Reset すれば起動する、と言っている方もいます(参照: 本家フォーラムの投稿)。
- 解決のためには、きちんとしたユーザレポートが必要と思われます。
-- 私のPCでは、この現象は発生していません。

◎現時点でユーザに出来ること
- v1.9.0 を使う前に、グラフィックカードのドライバを最新にしてください。
- 「黒い壁」のトラブルが起きている場合は、アップデート版を待つのが賢明です。
- 「loading scenery objects」画面で止まる問題が起きている方は、マシン環境や起動時オプション、メッセージ出力などの詳細なユーザレポートを本家フォーラムに報告しましょう。
-- 日本のユーザ内での情報共有という意味で本フォーラムに報告していただけるなら、それはそれで助かります。

◎新たに気づいた点
- FlightGear Wizard (fgrun 1.5.0) が 500MB 近いメモリを消費する事がある
-- 機体選択画面で、いくつもの機体をクリックすると、クリックした機体の種類が増えるたびに使用メモリが増加することをタスクマネージャ上で確認
--- 機体の3Dモデルのプレビュー描画がメモリを消費していると思われる
--- 初期インストール済みの機体を全てクリックした場合、約450MBのメモリを使用
-- fgrunが大量のメモリを消費した状態で FlightGear を起動すると、FlightGear 自身がさらに約 450MB のメモリを使用
-- 搭載メモリ量が 1GB またはそれ以下の場合、ハードディスクへのスワップが発生し、FlightGear の起動と終了に時間がかかる要因となる恐れ有り
# DDR2 2GBで1000円の安物メモリを明日買いに行って来ます!

◎先進的なユーザの皆さん向け

引用:

Tatさんは書きました:
--prop:/sim/rendering/camera-group/near-field=0 を指定して起動すると
Near カメラのみで描画するので、マルチビューで発生するドライバのバグは回避できることになりますね。
この(とりあえずの)回避方法が適用された FlightGear/CVS のWindows用スナップショットが12/30付けで公開されました。
早速試してみましたので以下にレポートします。
興味のある方はどうぞご覧ください。

(注意)
- この12/30付けのスナップショットはテスト目的でのみの使用をお勧めします。
- これ以降に、更なる(根本的な)修正がソースに加わっていますが、それが反映された Windows 用スナップショットはまだアップロードされていません。

(手順) v1.9.0 をインストールしている事が前提
- ftp://ftp.ihg.uni-duisburg.de/FlightGear/Win32/ より fgrun+fgfs-osg-win32-20081230.zip をダウンロード
- 解凍して、フォルダ名を Win32 にリネームし、v1.9.0の FlightGear/bin/Win32 と置き換え

(テスト1) 通常の起動時 (NearカメラとFarカメラを使用して描画)
- 黒い壁が発生
- フレームレートは20〜24 fps
- 起動オプションとメッセージ出力:
>"C:\Program Files\FlightGear1.9.0\
bin\Win32\fgfs.exe"  --fg-root="C:\Program Files\FlightGear1.9.0\data"  --fg-sce
nery="C:\Program Files\FlightGear1.9.0\data\Scenery;C:\Program Files\FlightGear1
.9.0\scenery;C:\Program Files\FlightGear1.9.0\terrasync"
  Model Author:  Unknown
  Creation Date: 2002-01-01
  Version:       $Id: c172p.xml,v 1.20 2008/09/01 15:14:33 torsten Exp $
  Description:   Cessna C-172
FGMultiplayMgr - No receiver port, Multiplayermode disabled
KI266 dme indicator #0 initialized
RenderStage::runCameraSetUp(), FBO setup failed, FBO status= 0x8cdd
RenderStage::runCameraSetUp(), FBO setup failed, FBO status= 0x8cdd
Initializing Nasal Electrical System
power up

(テスト2) --prop:/sim/rendering/camera-group/near-field=0 を指定 (Nearカメラのみで描画)
- 黒い壁は発生しない
- フレームレートは30 fps で安定
- 起動オプションとメッセージ出力:
    >"C:\Program Files\FlightGear1.9.0\
    bin\Win32\fgfs.exe"  --fg-root="C:\Program Files\FlightGear1.9.0\data"  --fg-sce
    nery="C:\Program Files\FlightGear1.9.0\data\Scenery;C:\Program Files\FlightGear1
    .9.0\scenery;C:\Program Files\FlightGear1.9.0\terrasync" --prop:/sim/rendering/c
    amera-group/near-field=0
      Model Author:  Unknown
      Creation Date: 2002-01-01
      Version:       $Id: c172p.xml,v 1.20 2008/09/01 15:14:33 torsten Exp $
      Description:   Cessna C-172
    FGMultiplayMgr - No receiver port, Multiplayermode disabled
    KI266 dme indicator #0 initialized
    RenderStage::runCameraSetUp(), FBO setup failed, FBO status= 0x8cdd
    Initializing Nasal Electrical System
    power up

(実行環境)
- Windows XP Media Center Edition 2002 SP2
- NVIDIA GeForce 6150 LE (on board), latest 178.24 driver, 1680x1050, 60Hz, 16bit
- AMD Athlon 64 X2 3600+ 1.9GHz
- 1GB DDR2-SDRAM

p.s.
申し遅れましたが、皆様明けましておめでとうございます。
今年も FlightGear を楽しみましょう!
投票数:32 平均点:4.06
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2009-1-2 11:36 | 最終変更
toshi  長老   投稿数: 1529
新しい windows用 cvs スナップショットが公開されました。

FlightGear 1.9.0 (fgsetup-1.9.0.exe) をインストールした後に、 ftp://ftp.uni-duisburg.de/FlightGear/Win32/ から fgrun+fgfs-osg-win32-20090101.zip をダウンロードしてください。

その後、zipファイルを解凍して、フォルダ名を Win32 にリネームし、v1.9.0の FlightGear\bin\Win32 と置き換えてください。

ソースコードに加わった新たな修正により、少なくとも私の環境では、デスクトップの色設定が16bitであっても黒い壁は発生しなくなりました。

--prop:/sim/rendering/camera-group/near-field=0 オプションをつけずに、普通に起動して大丈夫そうです。

ただし、現時点では、
o 起動時に「loading scenery objects」画面で非常に時間がかかる
という問題に対する対処は行われていないと思います。

また、ソースコードの修正が頻繁に行われている状況ですので、特にこれから初めて FlightGear をインストールしようと思っている一般ユーザの方はもう少し様子を見たほうが良いと思います。
投票数:13 平均点:3.08
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2009-1-4 11:58
hide  長老 居住地: 兵庫県  投稿数: 650
hideです。
 私も年末に fgsetup-1.9.0.exe をインストールしました。
デスクトップの色設定が16bitの場合は、Wizardで機体選択後、
起動を試みると以下のエラーメッセージが出て、Aborting...が
表示され、Wizardに戻りました。

 Error:[Screen #0] GraphicsWindowWin32::setPixelFormat()
- No matching pixel format found on traits specified

 幸い32bitでは無事に起動し、「黒い壁」はなく、起動時間も
わずかに延びたかな、という程度です。フレームレートはKSFO
付近で約30、シスコ市街中心で約20をマークし、なかなか快適
です。以下は私の環境です。

・Intel Core(TM)2 Duo 2.19GHz 2.00GB RAM
・Win-XP SP3
・GeForce8400

●約70機種を起動テスト:
 その後デフォルト機種に、08年リリース分を中心に追加して、
約70機種の起動テストを行い、結果は次の通りでした。

・起動不可、または正常に作動しないもの:
 X15
 B29
 C310
 Camel(車輪止めが消えず、離陸できない)
 Carreidas(テクスチャーファイルが無効)
 Hansajet
 mosquito(スロットルを開いても動かず)
 OV10ブロンコ
 PBYカタリナ飛行艇(エンジン始動不可)
 pc6

・他機のファイルに依存し、単独では起動できなかった機体:
 Beaufighter
 F4U

 …ブロンコにつきましては、FlightGearの黒いモニター画面に
エラーメッセージがくり返し流れ、ループに入って暴走している
感じです。私が改造した軍用タイプばかりでなく、デフォルト状
態のNASA・消防仕様機も同様です。
 暴走は、いじっているうちに停止して、新たに別のメッセージ
が出ましたので、画面コピーをマイアルバムに転載します。ブロ
ンコ改が使えないのは残念ですが、やや古い機体ですし、こんな
こともあるだろうと思って、すでに代替機を準備中です。

●パソコン「休止」に時間が掛かる:
 前述の70機種起動テスト後、パソコンを「休止」状態に入れる
際、極めて時間が掛かるようになりました。従来は約1分でしたが
現在は10分近く掛かります。
 登録機体を約40に減らし、「休止」機能をオフにして、ついで
にページファイルもゼロにし、「移動できないファイル」を無く
した上で、デフラグを掛けてから元に戻してみましたが、変化は
ありません。これはtoshiさんが確認された、使用メモリの増加と
関連がありそうですね。
 1.9.0を巡る問題は、目下この程度です。

では皆様、今年も Happy Flight & Happy Landing!!!
投票数:16 平均点:4.38
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2009-1-12 8:56
toshi  長老   投稿数: 1529
引用:

toshiさんは書きました:
o 起動時に「loading scenery objects」画面で非常に時間がかかる
- 私の知る限りですが、解決策は不明です。

新しい windows用 cvs スナップショット が公開されました。
ftp://ftp.ihg.uni-duisburg.de/FlightGear/Win32/fgrun+fgfs-osg-win32-20090111.zip

これまでに起動時に非常に時間のかかる問題が発生していた方は、これで解決するかもしれません。

(FlightGear-devel のアナウンス)
http://www.mail-archive.com/flightgear-devel@lists.sourceforge.net/msg20371.html

(英語フォーラムのフィードバック先)
Re: Scenery problem fg 1.9.0
- http://www.flightgear.org/forums/viewtopic.php?f=11&t=2725&start=15#p24518

Re: 1.9.0 upgrade seems to be a failure. [possible fix inside]
- http://www.flightgear.org/forums/viewtopic.php?f=2&t=2705&start=15#p24515
投票数:13 平均点:5.38

なし Re: FlightGear v1.9.0 リリース

msg# 1.8.1.1.1.1.2.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2009-1-12 14:04
BBCTV  常連 居住地: 茨城県、日本国  投稿数: 96
メーリングリストからすると、バージョン名は1.9.1として扱われているのですか?
投票数:8 平均点:6.25

なし Re: FlightGear v1.9.0 リリース

msg# 1.8.1.1.1.1.2.1.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2009-1-12 14:47 | 最終変更
toshi  長老   投稿数: 1529
引用:

BBCTVさんは書きました:
メーリングリストからすると、バージョン名は1.9.1として扱われているのですか?
fgrun+fgfs-osg-win32-20090111.zip はバージョン 1.9.1 なのか、とういうご質問なのでしたら、そうではありません。
次期リリースに向けて開発中の段階にある CVS 版の、2009-01-11 時点の windows バイナリ スナップショットです。
さらに改良が加えられた後、バージョン 1.9.1 か何かの番号が付いてリリースされることでしょう。

CVS 版はソースコードのみが日々更新されています。
実行可能なバイナリ形式の windows 用の CVS スナップショットは (通常は) 約1週間に1回公開されています。
FlightGear 1.9.0 がリリースされた後、今回のスナップショットは (早くも) 5回目の公開になります。
今回公開されたスナップショットには、Windows 環境でシーナリーのロード画面で異常に時間がかかる不具合を修正するコードが含まれています。
ただし、開発者の環境では元々そのような不具合が発生していなかったため、ユーザからのフィードバックを求めるために本家フォーラム等で特別にアナウンスがされています。

もし違う事をお聞きになりたいのでしたら、すみませんが質問の内容をもう少し詳しく書いてください。
投票数:10 平均点:4.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2009-1-14 2:40 | 最終変更
toshi  長老   投稿数: 1529
hide さん

本題からそれてスミマセン。

引用:
hideさんは書きました:
・Intel Core(TM)2 Duo 2.19GHz 2.00GB RAM
・Win-XP SP3
・GeForce8400
引用:
●パソコン「休止」に時間が掛かる:
 前述の70機種起動テスト後、パソコンを「休止」状態に入れる
際、極めて時間が掛かるようになりました。従来は約1分でしたが
現在は10分近く掛かります。
 登録機体を約40に減らし、「休止」機能をオフにして、ついで
にページファイルもゼロにし、「移動できないファイル」を無く
した上で、デフラグを掛けてから元に戻してみましたが、変化は
ありません。これはtoshiさんが確認された、使用メモリの増加と
関連がありそうですね。

私の感では、FlightGear は関係なくて、最近インストールしたドライバが影響しているのではないか、と思います。
ひょっとすると、何かアドバイスできるかもしれませんので、まずは (懐かしの) HDBENCH の結果を見せていただけませんか?
http://www.forest.impress.co.jp/lib/sys/hrdbnch/benchmark/hdbench.html

hdbench.exe を実行し、[ALL] でテストした後に [Copy] を押すとクリップボードに結果がコピーされますので、ここに貼り付けてみてください。
投票数:17 平均点:4.71
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2009-1-14 13:21
hide  長老 居住地: 兵庫県  投稿数: 650
toshiさん、hideです。

 ご心配を頂きまして、大変ありがとうございます。
さっそくHDBENCHを試してみました。以下に結果をお目に掛けます。
なお、最近更新した記憶のあるドライバは、ビデオカードくらいです。


★ ★ ★ HDBENCH Ver 3.30 (C)EP82改/かず ★ ★ ★
M/B Name
Processor Dual Pentium III 2197.15MHz[GenuineIntel family 6 model F step A]
VideoCard NVIDIA GeForce 8400M G
Resolution 1280x800 (32Bit color)
Memory 2096,364 KByte
OS 5.1 (Build: 2600) Service Pack 3
Date 2009/01/14 13:12

Intel(R) ICH8M Ultra ATA Storage Controllers - 2850
プライマリ IDE チャネル
HL-DT-ST DVDRAM GSA-T20N

Intel(R) ICH8M 3 port Serial ATA Storage Controller - 2828
プライマリ IDE チャネル
WDC WD1200BEVS-00UST0

Intel(R) ICH8M 3 port Serial ATA Storage Controller - 2828
セカンダリ IDE チャネル

ALL Integer Float MemoryR MemoryW MemoryRW DirectDraw
65235 315643 208863 173055 118988 235724 25

Rectangle Text Ellipse BitBlt Read Write Copy Drive
29636 22803 4293 722 34477 8000 3059 C:\100MB
投票数:21 平均点:5.71
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2009-1-16 2:18 | 最終変更
toshi  長老   投稿数: 1529
hide さん、こんばんは。

残念ながら、一つの可能性として私が考えていた事象は hide さんの環境には当てはまらないことが分かりました。

NVIDIA のチップセットを使っていて、nForce チップセットドライバをインストールする際に、NVIDIA の IDE ドライバを一緒にインストールしてしまうと休止状態に時間がかかる現象が発生することががあるようなのですが、hide さんのチップセットは intel ですので、このケースは当てはまりませんね。

ですので、あまり有用なアドバイスは出来なさそうです。

それにしても、休止状態に10分近くかかるのは尋常じゃないですね。
Windows 起動した後、FlightGear を実行するかしないかに係わらず、休止状態に入るまでに時間がかかってしまうのでしょうか?

他の (より低い) 可能性として私が考えていたのは、もし intel からチップセットドライバの最新版が提供されていれば、アップデートすると良いかもしれません。

あるいは、HDBENCH の結果からすると問題のある可能性は低いですが、ハードディスクの転送モードを一応確認しておくと良いかもしれません。
デバイスマネージャで「Intel(R) ICH8M 3 port Serial ATA Storage Controller - 2828」の「プライマリ IDE チャネル」の「詳細設定」を見るか、あるいは CrystalMark 2004R3 などのベンチマークソフトを使うと分かると思います。
ベンチマーク結果を他の似たような環境の人の結果と比べてみて、問題を探ってみる手もあるかもしれません。

あとは、NVIDIA の GeForce ドライバをダウングレードしてみるとか...
今のところ思いつくのはこれくらいです。
投票数:18 平均点:5.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2009-1-16 21:38
hide  長老 居住地: 兵庫県  投稿数: 650
hideです。
 toshiさん、詳細なフォローを頂き、大変ありがとうございました。

>Windows 起動した後、FlightGear を実行するかしないかに係わらず、
>休止状態に入るまでに時間がかかってしまうのでしょうか?
 …説明不足で済みません。
今回のトラブルは、FlightGearの起動の有無とは無関係に、パソコン
の再起動直後でも起きています。また、GeForceドライバのアップデー
トは、休止の問題が起きた後だったと思います。

>デバイスマネージャで「Intel(R) ICH8M 3 port Serial ATA Storage
> Controller - 2828」の「プライマリ IDE チャネル」の「詳細設定」
>を見る
 以上を、さっそく試しましたところ、次のような表示が現われました。
デバイス0
 デバイスの種類:「自動検出」  ←非アクティブ表示
 転送モード  :「DMA(利用可能な場合)」
 現在の転送モード:「ウルトラDMAモード2」
デバイス1
 デバイスの種類:「自動検出」  ←アクティブ表示
 転送モード  :「DMA(利用可能な場合)」
 現在の転送モード:「無効」
…これは、どのように解釈したらよろしいのでしょうか。

 なお、改めて「休止」動作を試したところ、今回も約12分掛かりました。
休止からの再起動は、パスワード入力画面までが約25秒、完全起動までで
すと約30秒で、まずは正常でした。
 念のためウイルス対策ソフトで、Cドライブのスキャンを実施しましたが、
約12万6000のファイルを対象にした場合、所要時間は23分28秒でした。
これは従来と、特に変化はないと思います。
投票数:12 平均点:5.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 .2 | 投稿日時 2009-1-22 0:54 | 最終変更
toshi  長老   投稿数: 1529
Tat さん

英語フォーラムに、Mac版のインストールで困っているユーザがいるようです。
http://www.flightgear.org/forums/viewtopic.php?f=11&t=2862

今のところ誰もフォローしてませんので、一応お知らせしておきます。
# マウントしていないのでファイルを書き込めない、とか?
投票数:8 平均点:5.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2009-1-29 0:34 | 最終変更
toshi  長老   投稿数: 1529
追加情報です。

NSAutoreleaseNoPool() は Mac 特有のエラーのようです。
http://d.hatena.ne.jp/E_Mattsan/20081009/1223559081#c100096292
投票数:12 平均点:5.83
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2009-1-30 5:16
Tat  長老   投稿数: 375
toshi さん

ご報告頂きありがとうございます。コメントを書いておきました。

インストールパッケージをマウントして、そこから直接起動したようですね。
Mac 版は GUI ランチャの起動時に $FG_ROOT へのエイリアスを作成するのですが、最初にインストールパッケージのディスクイメージから直接起動した場合、ディスクイメージをマウントしたフォルダ内にある FG_ROOT へのエイリアスを作成してしまいます。

ところが次の起動時には、通常そのフォルダは存在しないので、こういうエラーが出てしまいます。ついでに GUI のアップデートも行って欲しいとの旨も記しておきました。実は幾つかの問題があったので...
投票数:12 平均点:4.17
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2009-1-30 5:32
Tat  長老   投稿数: 375
引用:

toshiさんは書きました:
追加情報です。

NSAutoreleaseNoPool() は Mac 特有のエラーのようです。
http://d.hatena.ne.jp/E_Mattsan/20081009/1223559081#c100096292

わざわざ調べて頂いたようですね。ありがとうございました。

GUI 起動時のこのエラーは無視して構いません。GUI ランチャ で利用している RubyCocoa でスレッドを利用する際に、Mac にプリインストールされた ruby にパッチが当っていないと出るものです。若干メモリリークを起こす可能性があるのであまりよろしくは有りませんが、プリインストールされている ruby へパッチを当てることは出来ないため対処できていません。次の OS Update でパッチが当っている事を期待しましょう。

いずれにしても、FG本体やGUIランチャが動作しない原因にはなりませんのでご安心ください。念のためご報告しておきます。
投票数:14 平均点:5.71

なし Re: FlightGear v1.9.0 リリース

msg# 1.8.1.1.1.1.2.1.1.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2009-1-30 23:33
sambar  長老 居住地: 岡山  投稿数: 484
FlightGear 1.9.1bが1/25にリリースされました。
まだインストールしていませんが、リリースノートによれば1.9.0のバグフィックス版です。


http://www.flightgear.org/announce.html#v1.9.1

私の非公式ミラーftpにもあります。
投票数:9 平均点:3.33
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2009-2-4 1:34 | 最終変更
toshi  長老   投稿数: 1529
Tatさん

詳しくご説明いただきありがとうございました。

お節介ついでにちょっと思ったのですが、FlightGear をダウンロードしようとする海外の Mac ユーザは、ほぼ全員が http://macflightgear.sourceforge.net/home/downloads/ を訪問すると思います。

でも、インストール方法のドキュメント http://macflightgear.sourceforge.net/home/documents/users-guide/ を見てくれる人は限られてしまうために、今回のような質問が出るのではないか、と想像しています。

次回のリリースでは、ダウンロードするファイルへのリンクのすぐ後に、
See install instruction.
みたいなリンクを作って、ドキュメントページに誘導してみてはいかがでしょうか。
投票数:14 平均点:3.57
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2009-2-4 19:59
Tat  長老   投稿数: 375
toshi さん

なるほど、そうですね。ダウンロードリンクの所に、そのように書いておきます。

ただ、今までの経験からユーザの多くはドキュメントを読んでくれないのが現状です。これ迄に受けたメールやフォーラム投稿の9割はインストールパッケージに含まれる ReadMe に書かれている事です。ちなみにそのファイルはフライトギアアイコンのとなりにあり、ダブルクリックで読めます。また、GUI のヘルプからはサイト上のガイドを開くようになっていますが、あまり読まれてないですね。

ということは、やはりああいう問題そのものを残してはいけないということです。1.9.0 リリース直前に発覚した問題ですが、やはり時間がかかっても解決しておくべきだったと思っています。何れにしても「使い勝手のよい」ソフトで、直感的に使えるなら HelpMe メールやポストは減ると信じていますので、これからも精進して行きます。
投票数:16 平均点:5.63
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2009-2-6 18:33
r.naka  常連 居住地: 京都  投稿数: 31
皆さん、お久しぶりです。
r.nakaです。
このたび私も Flight Gear v1.9.0をダウンロードしました。
しかし起動して5分ぐらいたつととてもフレームレートが低下してしまいます。
これはバージョンが新しくなったせいなのでしょうか?
投票数:9 平均点:5.56
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2009-2-6 19:50 | 最終変更
toshi  長老   投稿数: 1529
こんばんは。

起動して約5分後にフレームレートが低下するという現象は初耳ですので、動作環境や起動オプションなどを詳しく知りたいところです。

ですがその前に、FlightGear 1.9.0 をアンインストールし、代わりに 1.9.1 をインストールしてください。
1.9.1 は 1.9.0 のバグ修正版であり、いくつかの深刻な問題が改善されています。

その後、引き続き問題が発生するようでしたら、1.9.1 のスレッドで状況を詳しく教えて下さい。
投票数:12 平均点:5.00

  条件検索へ


 検索

高度な検索
 新しい登録ユーザ
ypehoqy 2024-5-25
ugeqedo 2024-5-25
cusi857 2024-5-25
afyniqi 2024-5-25
cus958 2024-5-25
ahysijo 2024-5-25
udisufyr 2024-5-24
ehexuh 2024-5-24
ozedybav 2024-5-24
bromo72 2024-5-24
 最近の画像(画像付)
自作11機目 F/A-18... (2022-5-27)
自作11機目 F/A-18...
飛んでみる八尾空港 (2022-4-10)
飛んでみる八尾空港
作ってみる八尾空港 (2022-4-2)
作ってみる八尾空港
F117 nighthawk (2021-5-19)
F117 nighthawk
HiTouchさん宛の画像... (2020-11-8)
HiTouchさん宛の画像...
Powered by XOOPS Cube 2.1© 2001-2006 XOOPS Cube Project
Theme designed by OCEAN-NET