logo
ホーム •  フォーラム •  日本語wikiトップ •  アカウント情報 •  サイト内検索 •  新規登録
 ログイン
ユーザー名:

パスワード:


パスワード紛失

新規登録
 メインメニュー
 米国サイト
 オンライン状況
36 人のユーザが現在オンラインです。 (6 人のユーザが フォーラム を参照しています。)

登録ユーザ: 0
ゲスト: 36

もっと...

Flightgear 2020.1.1で音が出ない問題

  • このフォーラムに新しいトピックを立てることはできません
  • このフォーラムではゲスト投稿が禁止されています
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 .2 .3 | 投稿日時 2020-8-11 17:56
sakana    投稿数: 2
はじめまして

現在、Flightgear 2020.1.1を使用して海外各所のフライトを楽しんでいます。

しかし、昨日起動してフライトを楽しもうとしたのですけど

音が出ない問題が発生して、困ってます

どなたか、ご教示してくださると幸いです。

よろしくお願いします

・機体
Flightgearのランチャー(fgfs)から入手したB777-300
Flightgearのランチャーに元々入ってたCessna 172P Skyhawk
・OS
Linux Mint Ulyama (focal)
・問題の現象
起動して、エンジンを起動しても回転音などの音が全く聞こえない
・試したこと
1.Flightgearを再インストール(解決せず)
2.PC再起動 (解決せず)

初心者で、まだまだ至らないところもありますけど、よろしくお願いします。
投票数:0 平均点:0.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2020-8-13 4:00 | 最終変更
toshi  長老   投稿数: 1291
sakanaさん、こんばんは。
toshiです。

FlightGearメイン画面の上部のメニューバーにある
File > Sound Configuration
で、
・MasterとEffectsがEnabledになっていること
・MasterとEffectsの音量スライダーが5割から7割以上に設定されていること
を確認してみてください。

Windows環境ではあまり聞かない症状なので、Linux特有の何かがあるかもしれません。
最近はLinux環境に疎くてお役に立てないかもしれませんが、
File > Sound Configuration
で、
・Sound Device:
の選択肢として何が表示されているかを教えてください。

また、
~/.fgfs/fgfs.log
にFlightGear実行中のログが記録されていると思いますが、Audioやsoundに関するエラーが含まれていたら、その内容を教えてください。

--
p.s. 英語フォーラムの方でも質問されていたことに、後から気付きました。
もし、英語フォーラムの回答文で英語の意味が分からないところがあれば、こちらの日本語フォーラムで「この文章はどういう意味?」とお尋ねいただければ適宜サポートしますので、ご相談ください。
https://forum.flightgear.org/viewtopic.php?f=24&t=37825
投票数:0 平均点:0.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2020-8-13 8:49
sakana    投稿数: 2
返信ありがとうございます
Sound Deviceの選択肢は…何もありませんね…
あと、Audioだと
/build/simgear-zthhgx/simgear-2020.1.1/simgear/sound/soundmgr_openal.cxx:864: Error: Default audio device not available.
っていうエラーが発生しています。
投票数:0 平均点:0.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2020-8-14 20:57
toshi  長老   投稿数: 1291
toshiです。

Sound Device:の選択肢が何も表示されないこと、fgfs.logに
/build/simgear-zthhgx/simgear-2020.1.1/simgear/sound/soundmgr_openal.cxx:864: Error: Default audio device not available.
というエラーが表示されていること、この2点とも本来とは異なる状態で、音が聞こえない問題に関する重要な手がかりだと思います。

状況からすると、FlightGearが利用しているサウンドライブラリOpen ALがサウンドデバイスを見つけられていないように思います。
/etc/openal/alsoft.conf の内容と、~/.alsoftrc (もしあれば)の内容を教えてください。

FlightGear 2020.1.1のインストール時は正常に出力されていた音が、FlightGearの効果音だけ8/10から急に聞こえなくなったということですと、OpenAL、ALSA、PulseAudioのいずれかの設定が8/10ごろに変更されてしまったのではないかと思うのですが、サウンド関連の設定が変更される原因に何か心当たりはありませんでしょうか?
# システムをアップデートした、何かのソフトをインストールした、ヘッドホンやスピーカの接続を変更した、など。

英語フォーラムの投稿を拝見するに、Linux MintのFlightGearパッケージをインストールしなおしたようですが、現在のFlightGearのバージョンと、fgfs.logのサウンド関連のログ内容も教えてください。
投票数:0 平均点:0.00

  条件検索へ


 検索

高度な検索
 新しい登録ユーザ
voip 2020-9-25
urszuladzi 2020-9-25
Entloaded 2020-9-25
cowimud 2020-9-25
ofywu 2020-9-25
unigamu 2020-9-25
oqysej 2020-9-25
yduxyla 2020-9-25
initoxem 2020-9-25
gallery 2020-9-25
 最近の画像(画像付)
あきづきに着艦訓練 (2020-5-24)
あきづきに着艦訓練
反映確認飛行 (2020-5-17)
反映確認飛行
AI艦船 護衛艦あき... (2020-5-16)
AI艦船 護衛艦あき...
コックピット内の謎... (2020-5-16)
コックピット内の謎...
FA-200に180ps仕様を... (2020-2-22)
FA-200に180ps仕様を...
Powered by XOOPS Cube 2.1© 2001-2006 XOOPS Cube Project
Theme designed by OCEAN-NET